Search
Close this search box.

MIKROTIK BACKUP CLOUD SUR TELEGRAM (Partie 2)

Etape 1 : Créer un Bot Telegram

.Bot Father

Nous allons créer un Bot Telegram avec Botfather.

Lien pour Botfather : https://t.me/BotFather

Après avoir créer votre Bot telegram, vous devez copier et garder votre API Token. Nous allons ensuite remplacer XXXXXXXXXXXXXXXXXXXX dans notre script par le API Token de notre Bot.

Après le Bot, nous avons besoin du Chat ID, qui est notre identifiant unique sur Telegram. Pour obtenir le chat id, nous allons utiliser un Bot qui s’appel get id bot, il suffit de lancer ce bot pour automatiquement avoir chat ID. Copiez et remplacez par les YYYYYYYYYYYYYYYYYYYYYYY dans le script

Lien pour Get ID : https://t.me/getmyid_bot

Etape 2 : Configurez le Script Telegram

Remplacez le ZZZZZZ par votre mot de passe.

Ajoutez ce script dans le Scheduler du mikrotik en programment l’intervalle de backup.

/system backup cloud print;
delay 3s;
:log info massage="Backup : Phase 1 ---> print OK"
/system backup cloud remove-file number=0;
delay 2s;
:log info massage="Backup : Phase 2 ---> remove OK";
/system backup cloud upload-file action=create-and-upload password=ZZZZZZZZZ;
:log info massage="Backup : Phase 3 --->  OK";

:local cdn [ /system backup cloud print];
:local gkey [ /system backup cloud get value-name=secret-download-key number=0 ];
:local datetime "$[/system clock get date]  $[/system clock get time]";
:tool fetch url="https://api.telegram.org/botXXXXXXXXXXXXXXXXXXXXX/sendMessage?
chat_id=YYYYYYYYYYYYYY&text= \F0\9F\92\BE BACKUP CLOUD - MNA %0A %0A \E2\8F\B0 Date : $datetime%0A %0A
\\F0\9F\94\90 key : $gkey%0A %0A \F0\9F\94\90 Password : ZZZZZZZZZ " moode=http keep-result=no;
 

Automatisation d’envoie du backup sur Telegram à travers le Scheduler (le Backup se fera chaque 24H)

Script à lancer dans le terminal.

Leave a Comment

Your email address will not be published. Required fields are marked *

Share the Post:

Articles Similaires

Join Our Newsletter

Scroll to Top