Cloud backup sur telegram

MIKROTIK BACKUP CLOUD SUR TELEGRAM (Partie 2)

Etape 1 : Créer un Bot Telegram

•Bot Father

Nous allons créer un Bot Telegram avec BotFather.

Lien pour Botfather : https://t.me/BotFather

Après avoir créer votre Bot telegam, vous devez copier et garder votre API Token. Nous allons ensuite remplacer XXXXXXXXXXXXXXXXXXXXX dans notre script par le API Token de notre Bot.

Après le Bot, nous avons besoin du Chat ID, qui est notre identifiant unique sur Telegram. Pour obtenir le chat id, nous allons utilser un Bot qui s’appel get id bot. il suffit de lance ce bot pour automatiquement avoir votre chat ID. Copiez et remplace ça par les YYYYYYYYYYYYY dans le script

Lien pour Get ID : https://t.me/getmyid_bot

Etape 2 : Configurer le Script telegram

Remplacer le ZZZZZZ par votre mot de passe.

Ajouter ce script dans le scheduler du mikrotik en programmant l’interval de backup.

/system backup cloud print;
delay 3s;
:log info message="Backup : Phase 1 ---> print OK";
/system backup cloud remove-file number=0;
delay 2s;
:log info message="Backup : Phase 2 ---> remove OK";
/system backup cloud upload-file action=create-and-upload password=ZZZZZZ;
:log info message="Backup : Phase 3 --->  OK";

:local cdn [ /system backup cloud print];
:local gkey [ / system backup cloud get value-name=secret-download-key number=0 ];
:local datetime "$[/system clock get date] $[/system clock get time]";
:tool fetch url="https://api.telegram.org/botXXXXXXXXXXXXXXXXXXXXXXXXXX/sendMessage?chat_id=YYYYYYYYY&text= \F0\9F\92\BE BACKUP CLOUD - MNA %0A %0A \E2\8F\B0 Date : $datetime%0A %0A \F0\9F\94\90  key : $gkey%0A %0A \F0\9F\94\90  Password : ZZZZZZ  " mode=http keep-result=no;

Automatisation d’envoie du backup sur Telegram à travers le scheduler (le Backup se fera chaque 24H)

Script à lancer dans le terminal

Scheduler d’autobackup
Backup Mikrotik dans Telegram
Vidéo youtube

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée.